Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 12, 2025 - 01:30 EDT
Scheduled
To continue improving the performance, reliability, and security of our platform, we have scheduled a significant upgrade for our core database systems.
During this upgrade window, there will be a service disruption lasting up to 45 minutes. This temporary service disruption affects you only if your Marketing Cloud Account ID is between 1 and 999.
Users will still be able to log in to the application. However, during this time the following services will be unavailable: - Scheduled campaigns will be held in queue - Inbound email response handling will be held in queue - The API server will receive web service requests, but the response will be delayed - Processing for Journeys and Data Journeys will be delayed
Posted Aug 07, 2025 - 15:22 EDT
This scheduled maintenance affected: App Cluster (Application, API Server).