Quality of Service Disruption Alert
Incident Report for Maropost Marketing Cloud
Postmortem

The service disruption of the hosted landing pages was caused by a hardware failure at our cloud hosting provider. When this occurred, the affected services where immediately automatically routed to other hardware running online. This automated re-routing only lasted less than a minute.

The period that the hosted landing pages were unavailable was during the time that the disrupted endpoints were being re-mounted and restored to the new hardware.

In general, physical hardware failures at our cloud hosting provider are extremely rare but not never. We are looking into how we may add more fault-tolerance to our platform so that our services may recover more quickly in these cases.

Posted Jan 19, 2023 - 10:28 EST

Resolved
Our Engineering Team has confirmed that system health has been fully restored to baseline norms.

Hosted Landing Pages should now be fully operational for all clients. Thank you for your patience as we worked through this.

A Post Mortem of this incident will be posted within 2 business days.

If you continue to experience issues, please submit a ticket with our Support Team via support@maropost.com
Posted Jan 11, 2023 - 23:45 EST
Monitoring
Our Engineering Team has successfully implemented the solution to restore system availability. We are continuing to monitor system health to ensure that all aspects of our platform are fully recovered.

We apologize for the inconvenience, and will post an update as soon as we've confirmed the issue is fully resolved
Posted Jan 11, 2023 - 22:00 EST
Update
We are continuing to investigate the issue. Please visit this site for further updates.
Posted Jan 11, 2023 - 20:47 EST
Investigating
At 5:39PM on Jan 11, 2023 Eastern Time Zone, we became aware of a service disruption affecting our clients on specific components of our platform relating to the hosted landing pages.

Our Engineering Team is currently assessing the impact. We will post a status update as quickly as possible.

We apologize for the impact to your business. Thank you for your patience as we work to resolve this issue.
Posted Jan 11, 2023 - 18:14 EST
This incident affected: Cloud Cluster (Application), App Cluster (Application), and Cloud1 Cluster (Application).