Our Engineering Team has confirmed that system health has been fully restored to baseline levels.
All systems are now fully operational for all clients. Thank you for your patience and understanding while we worked to resolve this issue.
Posted Sep 15, 2026 - 16:06 EDT
Monitoring
Our Engineering Team has successfully implemented the solution to restore the "CDP – All Contacts" tab. We are continuing to monitor system health to ensure that all aspects of our platform are fully operational.
We apologize for the inconvenience, and will post an update as soon as we've confirmed the issue is fully resolved.
Posted Sep 15, 2026 - 15:46 EDT
Investigating
We are currently investigating an issue where contact data is not being displayed in the All Contacts tab within CDP. Our team is actively working to identify the cause and restore the affected functionality.
Posted Sep 15, 2026 - 14:31 EDT
This incident affected: App Cluster (Application, API Server).