Intermittant Login Issues

Incident Report for Maropost Marketing Cloud

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:25 EDT

Monitoring

Third-party services that enable Marketing Cloud users to login have been restored. We have confirmed that our users are able to consistently log in and access their Marketing Cloud accounts.

We will continue to monitor the situation over the next hour to confirm 100% service restoration.
Posted Jun 12, 2025 - 17:26 EDT

Identified

Our third-party provider has notified us they have identified the issue and are in the process of implementing the fixes.

We are continuing to monitor their status updates.
Posted Jun 12, 2025 - 17:15 EDT

Investigating

A third-party outage is having broad impact on the entire internet causing intermittent login issues to Marketing Cloud.

Maropost is continually monitoring the situation and will continue to update our status.
Posted Jun 12, 2025 - 16:03 EDT
This incident affected: Cloud Cluster (Application), App Cluster (Application), Cloud1 Cluster (Application), CA1 Cluster (Application), and EU1 Cluster (Application).