Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 13, 2026 - 01:00 EDT
Scheduled
Maropost is scheduled a scheduled upgrade to our platform. The maintenance window is scheduled for 2 hours. However, the anticipated service interruption will last approximately 10 minutes only.
The result of this upgrade will be a significant improvement in capacity and overall system performance.
During the period of service interruption, the following services are impacted: - Campaigns & Journeys (creation, editing, and saving will be unavailable) - Templates (creation and updates) - Data management (imports, API syncs, and list updates) - Campaigns scheduled during the downtime window may be slightly delayed
What to expect: - Downtime is limited to approximately 10 minutes - Reporting dashboards will remain accessible - Real-time analytics (opens/clicks) may have slight delays in updating
Posted Apr 09, 2026 - 15:11 EDT
This scheduled maintenance affected: Cloud Cluster (Application, API Server), App Cluster (Application, API Server), Cloud1 Cluster (Application, API Server), CA1 Cluster (Application, API Server), and EU1 Cluster (Application, API Server).