Failure to add tags via API calls
Incident Report for Maropost
Resolved
Our Engineering team has resolved the issues around tags added via API and confirmed that the impact of this issue was isolated to a small group of users on the app cluster only.

All systems should now be fully operational for all clients. Thank you for your patience as we worked through this.

If you continue to experience issues, Please submit a ticket with our support team via the contact form. https://support.maropost.com/hc/en-us/requests/new

This failure was caused by a logic error in a recent product enhancement which, due to a missed scenario in our regression testing was not caught before deployment. We have installed new procedures and safeguards as well as additional training and system monitoring to help our team catch mistakes before they are deployed and ensure this kind of event does not happen.
Posted Oct 02, 2019 - 13:49 EDT
Monitoring
Our engineering team has implemented a fix to resolve the issues adding tags via API and is actively monitoring the situation.

We apologize for the inconvenience, and will post an update as soon as we've confirmed the issue is fully resolved.
Posted Oct 02, 2019 - 11:44 EDT
Investigating
We are investigating a reported failure to add tags via API calls. During this time, users may experience tag issues. We apologize for the inconvenience and will post an update as soon as additional information is available.
Posted Oct 02, 2019 - 09:38 EDT
This incident affected: App (API).