App Cluster MySQL Connection Offline
Incident Report for Maropost
Resolved
Our Engineering team has fully resolved the issue around the App Cluster MySQL connection.

The backlog of campaigns held for delivery has been cleared. All campaigns are now being sent as scheduled. Thank you for your patience as we worked through this.

If you continue to experience issues, please submit a ticket with our support team via the contact form. https://support.maropost.com/hc/en-us/requests/new
Posted Oct 17, 2019 - 14:52 EDT
Monitoring
At 3:30am EST on 10/17/19 we discovered that a routine maintenance performed by Google Cloud Platform, our cloud hosting service provider, had an unintentional side effect upon our systems. While email open events have been captured, there was a delay in matching those opens with their original campaigns. During this period, there was a momentary delay in delivery only to campaigns whose targeted audience is based on prior campaign opens. Delivery of all other campaigns were not affected.

We are currently assessing the scope of the delay for these specific types of campaigns, and will post the details shortly.

At 8:30am EST, our engineering team implemented a fix to resolve the issue and everything was fully restored. We continue to monitor the situation and will provide an update if further issues persist.

Please note: Despite the backlog of open queue, every open will show you the exact time when it was actually opened once it is saved in the database.

We apologize for the inconvenience.
Posted Oct 17, 2019 - 11:03 EDT
This incident affected: App (Application).