Unable to log in to app.maropost.com
Incident Report for Maropost
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 15:09 EDT
Update
We are continuing to investigate this issue.
Posted Mar 17, 2020 - 15:09 EDT
Investigating
At 2:00 PM Eastern Time Zone, we became aware of a service disruption affecting our clients on the app cluster.

Our Engineering Team is currently assessing the impact. We will post a status update as quickly as possible.

We apologize for the impact on your business. Thank you for your patience as we work to resolve this issue.
Posted Mar 17, 2020 - 14:16 EDT
This incident affected: App (Application).